summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f397c6b..0aeb45a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,13 +17,14 @@ if (NOT DISABLE_PCITOOL)
pkg_check_modules(FASTWRITER fastwriter REQUIRED)
endif (NOT DISABLE_PCITOOL)
-add_definitions("-fPIC --std=c99 -Wall -O2 -gdwarf-2 -g3")
-#add_definitions("-fPIC --std=c99 -Wall -O2")
+check_include_files(stdatomic.h HAVE_STDATOMIC_H)
+
+add_definitions("-fPIC --std=c11 -Wall -O2 -gdwarf-2 -g3")
+#add_definitions("-fPIC --std=c11 -Wall -O2")
include(cmake/version.cmake)
VERSION_TO_VARS(${PCILIB_VERSION} PCILIB_VERSION_MAJOR PCILIB_VERSION_MINOR PCILIB_VERSION_MICRO)
-
add_subdirectory(dma)
add_subdirectory(protocols)
add_subdirectory(pcilib)