diff options
author | Rodolfo Carvalho <rhcarvalho@gmail.com> | 2017-02-20 17:36:36 +0100 |
---|---|---|
committer | Rodolfo Carvalho <rhcarvalho@gmail.com> | 2017-02-20 17:38:08 +0100 |
commit | 0d6535242db07968206b3af15046f62a30748449 (patch) | |
tree | a5113c1cb59ee2eab3eabde01aed46501a7f34b3 /setup.py | |
parent | 9492616511632c26bf42f786c6fba5f40f15d4d9 (diff) | |
download | openshift-0d6535242db07968206b3af15046f62a30748449.tar.gz openshift-0d6535242db07968206b3af15046f62a30748449.tar.bz2 openshift-0d6535242db07968206b3af15046f62a30748449.tar.xz openshift-0d6535242db07968206b3af15046f62a30748449.zip |
Fix validation of generated code
Importing modules with the same name will not reload an already imported
module. Explicitly reloading the module is the quickest fix.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -13,6 +13,7 @@ import yaml from setuptools import setup, Command from setuptools_lint.setuptools_command import PylintCommand from six import string_types +from six.moves import reload_module from yamllint.config import YamlLintConfig from yamllint.cli import Format from yamllint import linter @@ -185,6 +186,7 @@ class OpenShiftAnsibleGenerateValidation(Command): # the python path. # pylint: disable=import-error import generate + reload_module(generate) generate.verify() except generate.GenerateAnsibleException as gae: print(gae.args) |