summaryrefslogtreecommitdiffstats
path: root/roles/openshift_preflight
Commit message (Collapse)AuthorAgeFilesLines
* Replace multi-role checks with action pluginRodolfo Carvalho2017-02-1013-455/+0
| | | | | | | | | | | | | | | | | | This approach should make it easier to add new checks without having to write lots of YAML and doing things against Ansible (e.g. ignore_errors). A single action plugin determines what checks to run per each host, including arguments to the check. A check is implemented as a class with a run method, with the same signature as an action plugin and module, and is normally backed by a regular Ansible module. Each check is implemented as a separate Python file. This allows whoever adds a new check to focus solely in a single Python module, and potentially an Ansible module within library/ too. All checks are automatically loaded, and only active checks that are requested by the playbook get executed.
* Reword module documentationRodolfo Carvalho2017-02-101-6/+5
|
* Separate import groups with a blank lineRodolfo Carvalho2017-02-102-0/+3
|
* Remove commented-out debugging codeRodolfo Carvalho2017-02-102-28/+0
|
* Rename subrole facts -> initRodolfo Carvalho2017-01-133-2/+1
| | | | | | | | Trying to improve the name, `init` needs to be loaded before calling other subroles. We don't make `init` a dependency of `common`, `masters` and `nodes` to avoid running the relatively slow `openshift_facts` multiple times.
* Move Python modules into roleRodolfo Carvalho2017-01-138-3/+225
| | | | Allow reuse via role dependency.
* Fix inconsistent task nameRodolfo Carvalho2017-01-121-1/+1
|
* Reduce code duplication using variableRodolfo Carvalho2017-01-122-44/+14
| | | | | We can use openshift_facts's service_type to determine the package names.
* Replace custom variables with openshift_factsRodolfo Carvalho2017-01-125-9/+6
| | | | | | | Note: on a simple example run of ansible-playbook against a single docker-based host, I saw the execution time jump from 7s to 17s. That's unfortunate, but it is probably better to reuse openshift_facts, than to come up with new variables.
* Refactor preflight check into rolesRodolfo Carvalho2017-01-1210-0/+293