From dd2aea324c07fe1bd13143bb37eff11117b6130a Mon Sep 17 00:00:00 2001
From: "Suren A. Chilingaryan" <csa@suren.me>
Date: Thu, 24 Oct 2019 02:09:32 +0200
Subject: Dice(kiwi) and dependencies; kiwi and dependecies (still missing
 zypper)

---
 dev-ruby/rice/rice-2.1.3.ebuild | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 dev-ruby/rice/rice-2.1.3.ebuild

(limited to 'dev-ruby/rice/rice-2.1.3.ebuild')

diff --git a/dev-ruby/rice/rice-2.1.3.ebuild b/dev-ruby/rice/rice-2.1.3.ebuild
new file mode 100644
index 0000000..4f8d94c
--- /dev/null
+++ b/dev-ruby/rice/rice-2.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit ruby-fakegem
+RUBY_FAKEGEM_EXTRAINSTALL="ruby"
+
+DESCRIPTION="Rice is a C++ interface to Ruby's C API. It provides a type-safe and exception-safe interface in order to make embedding Ruby and writing Ruby extensions with C++ easier. It is similar to Boost.Python in many ways, but also attempts to provide an object-oriented interface to all of the Ruby C API."
+HOMEPAGE="https://rubygems.org/gems/rice/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+
+each_ruby_prepare() {
+    ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+    emake || die
+    find . -name *.o -delete
+}
+
+each_ruby_install() {
+    emake install || die    
+    each_fakegem_install
+}
-- 
cgit v1.2.3