summaryrefslogtreecommitdiffstats
path: root/build/linux/configure.ac
diff options
context:
space:
mode:
authorWillem Jan Palenstijn <wjp@usecode.org>2016-01-21 13:24:11 +0100
committerWillem Jan Palenstijn <wjp@usecode.org>2016-01-21 13:24:11 +0100
commitcd12edcd3ada212f27088a4e26e3eee5f89bcbad (patch)
treeee441dc41b25ac6fc7ad0b835917984fc4148187 /build/linux/configure.ac
parentd6c0f64358a75565e70905d11c47511329ec3c53 (diff)
parent6a7eaf9c8fee52e01e7a48cd7e4630453c033655 (diff)
downloadastra-cd12edcd3ada212f27088a4e26e3eee5f89bcbad.tar.gz
astra-cd12edcd3ada212f27088a4e26e3eee5f89bcbad.tar.bz2
astra-cd12edcd3ada212f27088a4e26e3eee5f89bcbad.tar.xz
astra-cd12edcd3ada212f27088a4e26e3eee5f89bcbad.zip
Merge pull request #110 from wjp/build
Build system improvements
Diffstat (limited to 'build/linux/configure.ac')
-rw-r--r--build/linux/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/build/linux/configure.ac b/build/linux/configure.ac
index 684a4c5..630b08d 100644
--- a/build/linux/configure.ac
+++ b/build/linux/configure.ac
@@ -213,12 +213,19 @@ assert(LooseVersion(Cython.__version__)>=LooseVersion("0.13"))
fi
AC_MSG_RESULT(yes)
AC_MSG_CHECKING(for six module)
- ASTRA_TRY_PYTHON([import six])
+ ASTRA_TRY_PYTHON([import six],,HAVEPYTHON=no)
if test x$HAVEPYTHON = xno; then
AC_MSG_RESULT(no)
AC_MSG_ERROR(You need the six module to use the ASTRA toolbox in Python)
fi
AC_MSG_RESULT(yes)
+ AC_MSG_CHECKING(for scipy module)
+ ASTRA_TRY_PYTHON([import scipy],,HAVEPYTHON=no)
+ if test x$HAVEPYTHON = xno; then
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(You need the scipy module to use the ASTRA toolbox in Python)
+ fi
+ AC_MSG_RESULT(yes)
fi
AC_SUBST(HAVEPYTHON)
@@ -236,6 +243,12 @@ esac
AC_SUBST(CPPFLAGS_OS)
+# For some reason, some older versions of autoconf produce a config.status
+# that disables all lines looking like VPATH=@srcdir@
+# (More recent autoconf fixes the too broad matching there.)
+# We use a different variable name as a workaround.
+VPATH_SRCDIR="$srcdir"
+AC_SUBST(VPATH_SRCDIR)
# TODO: