summaryrefslogtreecommitdiffstats
path: root/build/linux/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'build/linux/configure.ac')
-rw-r--r--build/linux/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/build/linux/configure.ac b/build/linux/configure.ac
index 0a9024e..c992516 100644
--- a/build/linux/configure.ac
+++ b/build/linux/configure.ac
@@ -120,6 +120,12 @@ if test x"$HAVECUDA" = xyes; then
AC_MSG_CHECKING([if nvcc works])
ASTRA_CHECK_NVCC(HAVECUDA,NVCCFLAGS_EXTRA)
AC_MSG_RESULT($HAVECUDA)
+
+ AC_MSG_CHECKING([if boost and CUDA versions are compatible])
+ ASTRA_CHECK_CUDA_BOOST(AC_MSG_RESULT([yes]),[
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([Boost and CUDA versions are incompatible. You probably have to upgrade boost.])
+ ])
fi
AC_ARG_WITH(cuda_compute, [[ --with-cuda-compute=archs comma separated list of CUDA compute models (optional)]],,)