summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Kulhanek <tomas.kulhanek@stfc.ac.uk>2019-01-21 17:15:29 +0000
committerGitHub <noreply@github.com>2019-01-21 17:15:29 +0000
commit9f186d5978aa4e528ea071d5de0a74edb71916ad (patch)
tree45411dd5255691fd4c8495652323c9293c8fb881 /CMakeLists.txt
parent34d0b9f85c3bc73416f1dc2bb25ef669b9ff8076 (diff)
parent60b4d51ce1cf19be2a3483232448ae227253614c (diff)
downloadregularization-9f186d5978aa4e528ea071d5de0a74edb71916ad.tar.gz
regularization-9f186d5978aa4e528ea071d5de0a74edb71916ad.tar.bz2
regularization-9f186d5978aa4e528ea071d5de0a74edb71916ad.tar.xz
regularization-9f186d5978aa4e528ea071d5de0a74edb71916ad.zip
Merge pull request #88 from TomasKulhanek/pr-test
Pr test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 550b896..b95107a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,10 @@ set (CIL_VERSION_MAJOR 0)
set (CIL_VERSION_MINOR 10)
set (CIL_VERSION_PATCH 2)
-set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}' CACHE INTERNAL "Core Imaging Library version" FORCE)
+# set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}' CACHE INTERNAL "Core Imaging Library version" FORCE)
+# get CIL_VERSION from environment variable and set it in cmake
+set (CIL_VERSION $ENV{CIL_VERSION} CACHE INTERNAL "Core Imaging Library version" FORCE)
+message(STATUS "CIL_VERSION set to " ${CIL_VERSION})
# set the Python variables for the Conda environment
#include(${CMAKE_SOURCE_DIR}/CMake/FindAnacondaEnvironment.cmake)