summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvagrant <vagrant@localhost.localdomain>2019-01-21 15:43:08 +0000
committervagrant <vagrant@localhost.localdomain>2019-01-21 15:43:08 +0000
commite4683c6c7be92ba65b13ef5ea4306948bcbded74 (patch)
tree9e52d5a10e4a9adddbff06a2bf5869bc91a875ad /CMakeLists.txt
parentcf9689e81bb69b7732a168463b17a47de1ef59a5 (diff)
downloadregularization-e4683c6c7be92ba65b13ef5ea4306948bcbded74.tar.gz
regularization-e4683c6c7be92ba65b13ef5ea4306948bcbded74.tar.bz2
regularization-e4683c6c7be92ba65b13ef5ea4306948bcbded74.tar.xz
regularization-e4683c6c7be92ba65b13ef5ea4306948bcbded74.zip
UPDATE: version from env
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 550b896..e3e59e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,9 @@ set (CIL_VERSION_MAJOR 0)
set (CIL_VERSION_MINOR 10)
set (CIL_VERSION_PATCH 2)
-set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}' CACHE INTERNAL "Core Imaging Library version" FORCE)
+# set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}' CACHE INTERNAL "Core Imaging Library version" FORCE)
+# get CIL_VERSION from environment variable
+set (CIL_VERSION $ENV{CIL_VERSION} CACHE INTERNAL "Core Imaging Library version" FORCE)
# set the Python variables for the Conda environment
#include(${CMAKE_SOURCE_DIR}/CMake/FindAnacondaEnvironment.cmake)