summaryrefslogtreecommitdiffstats
path: root/Wrappers/Python/setup.py
diff options
context:
space:
mode:
authorEdoardo Pasca <edo.paskino@gmail.com>2018-01-29 13:36:11 +0000
committerEdoardo Pasca <edo.paskino@gmail.com>2018-01-29 13:36:11 +0000
commit107eb18c28255c4c8dbdf8245ffb85fe6f7535d6 (patch)
treefe3fafc1d513fb278b85a31e1bd38f2f55df36cf /Wrappers/Python/setup.py
parente6ab844cd82080dab3a5f257fc15f4c1a20b498c (diff)
downloadregularization-107eb18c28255c4c8dbdf8245ffb85fe6f7535d6.tar.gz
regularization-107eb18c28255c4c8dbdf8245ffb85fe6f7535d6.tar.bz2
regularization-107eb18c28255c4c8dbdf8245ffb85fe6f7535d6.tar.xz
regularization-107eb18c28255c4c8dbdf8245ffb85fe6f7535d6.zip
renamed fista_module_gpu to gpu_regularizers.pyx
Cleaned test_cpu_regularizers.py
Diffstat (limited to 'Wrappers/Python/setup.py')
-rw-r--r--Wrappers/Python/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/Wrappers/Python/setup.py b/Wrappers/Python/setup.py
index 951146a..00c93fc 100644
--- a/Wrappers/Python/setup.py
+++ b/Wrappers/Python/setup.py
@@ -60,7 +60,7 @@ setup(
cmdclass = {'build_ext': build_ext},
ext_modules = [Extension("ccpi.filters.gpu_regularizers",
sources=[
- os.path.join("." , "src", "fista_module_gpu.pyx" ),
+ os.path.join("." , "src", "gpu_regularizers.pyx" ),
],
include_dirs=extra_include_dirs,
library_dirs=extra_library_dirs,
@@ -79,6 +79,7 @@ setup(
cmdclass = {'build_ext': build_ext},
ext_modules = [Extension("ccpi.filters.cpu_regularizers",
sources=[os.path.join("." , "src", "fista_module.cpp" ),
+ os.path.join("." , "src", "cpu_regularizers.pyx" )
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "FGP_TV_core.c"),
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "SplitBregman_TV_core.c"),
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "LLT_model_core.c"),