summaryrefslogtreecommitdiffstats
path: root/Wrappers/Python/setup.py
diff options
context:
space:
mode:
authorEdoardo Pasca <edo.paskino@gmail.com>2018-01-25 15:41:36 +0000
committerEdoardo Pasca <edo.paskino@gmail.com>2018-01-25 15:41:36 +0000
commitfc22de89c6ac689001a35cc4d7b213056a296798 (patch)
tree7555ae383bf24e0e6fcc95475d6c9f6ce5f44ed8 /Wrappers/Python/setup.py
parent93b6de991c7eb8b3ab96fc9ee01529fea614e326 (diff)
downloadregularization-fc22de89c6ac689001a35cc4d7b213056a296798.tar.gz
regularization-fc22de89c6ac689001a35cc4d7b213056a296798.tar.bz2
regularization-fc22de89c6ac689001a35cc4d7b213056a296798.tar.xz
regularization-fc22de89c6ac689001a35cc4d7b213056a296798.zip
added cython wrapper for gpu regularizers
Diffstat (limited to 'Wrappers/Python/setup.py')
-rw-r--r--Wrappers/Python/setup.py22
1 files changed, 21 insertions, 1 deletions
diff --git a/Wrappers/Python/setup.py b/Wrappers/Python/setup.py
index d2129b0..c535a34 100644
--- a/Wrappers/Python/setup.py
+++ b/Wrappers/Python/setup.py
@@ -58,8 +58,28 @@ setup(
description='CCPi Core Imaging Library - Image Regularizers',
version=cil_version,
cmdclass = {'build_ext': build_ext},
+ ext_modules = [Extension("ccpi.filters.gpu_regularizers",
+ sources=[
+ os.path.join("." , "src", "fista_module_gpu.pyx" ),
+ #os.path.join("." , "src", "multiply.pyx" )
+ ],
+ include_dirs=extra_include_dirs,
+ library_dirs=extra_library_dirs,
+ extra_compile_args=extra_compile_args,
+ libraries=extra_libraries ),
+
+ ],
+ zip_safe = False,
+ packages = {'ccpi','ccpi.filters'},
+)
+
+setup(
+ name='ccpi',
+ description='CCPi Core Imaging Library - Image Regularizers',
+ version=cil_version,
+ cmdclass = {'build_ext': build_ext},
ext_modules = [Extension("ccpi.filters.cpu_regularizers",
- sources=[os.path.join("." , "fista_module.cpp" ),
+ sources=[os.path.join("." , "src", "fista_module.cpp" ),
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "FGP_TV_core.c"),
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "SplitBregman_TV_core.c"),
# os.path.join("@CMAKE_SOURCE_DIR@" , "main_func" , "regularizers_CPU", "LLT_model_core.c"),