summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt78
1 files changed, 0 insertions, 78 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 762b308..d8af907 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -111,84 +111,6 @@ if (GOBJECT_INTROSPECTION_FOUND)
endif()
endif()
#}}}
-#{{{ Documentation
-pkg_check_modules(GTK_DOC gtk-doc)
-
-if(GTK_DOC_FOUND)
- option(WITH_GTK_DOC "Build documentation" ON)
-
- if (WITH_GTK_DOC)
- set(docs_dir "${CMAKE_CURRENT_BINARY_DIR}")
- set(docs_out "${docs_dir}/reference")
- file(MAKE_DIRECTORY ${docs_out})
-
- set(reference_files
- "${docs_out}/index.html"
- "${docs_out}/api-index-full.html"
- "${docs_out}/ch01.html"
- "${docs_out}/UcaCamera.html"
- "${docs_out}/UcaPluginManager.html"
- "${docs_out}/style.css"
- "${docs_out}/uca.devhelp2"
- "${docs_out}/home.png"
- "${docs_out}/left.png"
- "${docs_out}/right.png"
- "${docs_out}/up.png")
-
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/uca-docs.xml.in
- ${docs_out}/uca-docs.xml)
-
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/uca.types.in
- ${docs_out}/uca.types)
-
- # Create scangobj.sh from scangobj.sh.in
- get_directory_property(_current_include_dirs INCLUDE_DIRECTORIES)
- set(GTK_DOC_CFLAGS)
- foreach(_incl ${_current_include_dirs})
- set(GTK_DOC_CFLAGS "-I${_incl} ${GTK_DOC_CFLAGS}")
- endforeach()
-
- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/scangobj.sh.in" "${docs_out}/scangobj.sh")
-
- find_program(GTK_DOC_SCAN gtkdoc-scan REQUIRED)
- find_program(GTK_DOC_SCANGOBJ gtkdoc-scangobj REQUIRED)
- find_program(GTK_DOC_MKDB gtkdoc-mkdb REQUIRED)
- find_program(GTK_DOC_MKHTML gtkdoc-mkhtml REQUIRED)
-
- add_custom_command(OUTPUT ${docs_out}/uca-decl.txt
- COMMAND ${GTK_DOC_SCAN}
- --module=uca
- --source-dir=${CMAKE_CURRENT_SOURCE_DIR}
- DEPENDS uca
- WORKING_DIRECTORY ${docs_out})
-
- add_custom_command(OUTPUT ${docs_out}/uca.args
- COMMAND sh scangobj.sh
- DEPENDS uca ${docs_out}/uca-decl.txt
- WORKING_DIRECTORY ${docs_out})
-
- add_custom_command(OUTPUT ${docs_out}/sgml.stamp
- COMMAND ${GTK_DOC_MKDB}
- --module=uca
- --source-dir=${CMAKE_CURRENT_SOURCE_DIR}
- --output-format=xml
- DEPENDS ${docs_out}/uca.args
- WORKING_DIRECTORY ${docs_out})
-
- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/html.stamp
- COMMAND ${GTK_DOC_MKHTML}
- uca
- ${docs_out}/uca-docs.xml
- DEPENDS ${docs_out}/sgml.stamp ${docs_out}/uca-docs.xml
- WORKING_DIRECTORY ${docs_out})
-
- add_custom_target(reference ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/html.stamp)
-
- install(FILES ${reference_files}
- DESTINATION ${UCA_DATADIR}/gtk-doc/html/uca)
- endif()
-endif()
-#}}}
#{{{ Installation
install(TARGETS uca
LIBRARY DESTINATION ${UCA_LIBDIR}