summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 313b932..85feff4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -31,6 +31,9 @@ include_directories(
${CMAKE_CURRENT_BINARY_DIR}
)
+configure_file("config.h.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/config.h")
+
add_definitions("--std=c99 -Wall -O2 ${SSE_FLAGS}")
add_library(ufodecode SHARED ufodecode.c)
@@ -41,17 +44,10 @@ set_target_properties(ufodecode PROPERTIES
)
install(TARGETS ufodecode
- LIBRARY DESTINATION lib${LIB_SUFFIX}
+ LIBRARY DESTINATION ${LIBUFODECODE_LIBDIR}
)
install(FILES
ufodecode.h
- DESTINATION include
+ DESTINATION ${LIBUFODECODE_INCLUDEDIR}
)
-
-if ("${CMAKE_BUILD_TYPE}" MATCHES "Debug")
- set(DEBUG "1")
-endif()
-
-configure_file(config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)
-