summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2015-08-21 04:20:46 +0200
committerSuren A. Chilingaryan <csa@suren.me>2015-08-21 04:20:46 +0200
commitc392c9920f9baadc9267e726b46b9c64c82915c7 (patch)
tree91f3749ef5e3c3b2654348d2a9f3788452fde989 /CMakeLists.txt
parentfe3f8e3e172818741f32f5ea0bba27f77ca56a1a (diff)
downloadipecamera-c392c9920f9baadc9267e726b46b9c64c82915c7.tar.gz
ipecamera-c392c9920f9baadc9267e726b46b9c64c82915c7.tar.bz2
ipecamera-c392c9920f9baadc9267e726b46b9c64c82915c7.tar.xz
ipecamera-c392c9920f9baadc9267e726b46b9c64c82915c7.zip
Fix some warnings and add debugging information into the build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 788d9f6..7e38bd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,8 @@ set(IPECAMERA_ABI_VERSION "0")
cmake_minimum_required(VERSION 2.6)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+add_definitions("-fPIC --std=gnu99 -Wall -O2 -gdwarf-2 -g3 -fno-omit-frame-pointer")
+
find_package(PkgConfig REQUIRED)
find_package(Threads REQUIRED)
pkg_check_modules(UFODECODE ufodecode>=0.3 REQUIRED)