summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2015-09-17 16:32:51 +0200
committerSuren A. Chilingaryan <csa@suren.me>2015-09-17 16:32:51 +0200
commit924adedb2928f5657c6668f606dbb3294b3c45da (patch)
tree6f84a3f65fb7f0fde2f19a0a1e8f649af7478987 /CMakeLists.txt
parent4763e65fcf6288e94adc76a44c762a904f698e72 (diff)
downloadpcitool-924adedb2928f5657c6668f606dbb3294b3c45da.tar.gz
pcitool-924adedb2928f5657c6668f606dbb3294b3c45da.tar.bz2
pcitool-924adedb2928f5657c6668f606dbb3294b3c45da.tar.xz
pcitool-924adedb2928f5657c6668f606dbb3294b3c45da.zip
Reorder statements in CMakeLists.txt properly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10742fd..4c4c0d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,18 +51,6 @@ add_definitions("-fPIC --std=c99 -Wall -O2 -gdwarf-2 -g3 -fno-omit-frame-pointer
include(cmake/version.cmake)
VERSION_TO_VARS(${PCILIB_VERSION} PCILIB_VERSION_MAJOR PCILIB_VERSION_MINOR PCILIB_VERSION_MICRO)
-add_subdirectory(dma)
-add_subdirectory(protocols)
-add_subdirectory(pcilib)
-add_subdirectory(pcitool)
-add_subdirectory(apps)
-add_subdirectory(xml)
-
-set_target_properties(pcilib PROPERTIES
- VERSION ${PCILIB_VERSION}
- SOVERSION ${PCILIB_ABI_VERSION}
-)
-
set(TARNAME "pcitool")
set(PACKAGE_VERSION ${PCILIB_VERSION})
set(PACKAGE_NAME "${TARNAME}")
@@ -76,6 +64,18 @@ set(PCILIB_MODEL_DIR "${PCILIB_DATA_DIR}/models" CACHE PATH "Directory to instal
set(PCILIB_DOC_DIR "${CMAKE_CURRENT_BINARY_DIR}/docs/" CACHE PATH "Directory to install documentation")
set(PCILIB_DEBUG_DIR "." CACHE PATH "Directory to write debug information")
+add_subdirectory(dma)
+add_subdirectory(protocols)
+add_subdirectory(pcilib)
+add_subdirectory(pcitool)
+add_subdirectory(apps)
+add_subdirectory(xml)
+
+set_target_properties(pcilib PROPERTIES
+ VERSION ${PCILIB_VERSION}
+ SOVERSION ${PCILIB_ABI_VERSION}
+)
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/misc/pcitool.pc.in ${CMAKE_CURRENT_BINARY_DIR}/misc/pcitool.pc)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/pcilib/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/pcilib/config.h)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/pcilib/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/pcilib/version.h)