summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2016-04-06 23:20:30 +0200
committerSuren A. Chilingaryan <csa@suren.me>2016-04-06 23:20:30 +0200
commitf5deda971481e64c19ad49adf681124ef1417273 (patch)
tree7ea80b19f0095f594bc3f77ae3bd951ef7e1d4db /CMakeLists.txt
parent5e52f10edf41ecf464037ac381413042f09fe27f (diff)
downloadpcitool-f5deda971481e64c19ad49adf681124ef1417273.tar.gz
pcitool-f5deda971481e64c19ad49adf681124ef1417273.tar.bz2
pcitool-f5deda971481e64c19ad49adf681124ef1417273.tar.xz
pcitool-f5deda971481e64c19ad49adf681124ef1417273.zip
Further fixes for out-of-source compilation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f956d3a..10add39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,13 +47,17 @@ if (NOT DEFINED PCILIB_SERVER_DIR)
endif (NOT DEFINED PCILIB_SERVER_DIR)
if (NOT DEFINED PCILIB_DOC_DIR)
- set(PCILIB_DOC_DIR "${CMAKE_CURRENT_BINARY_DIR}/docs/" CACHE PATH "Directory to install documentation")
+ set(PCILIB_DOC_DIR "${CMAKE_BINARY_DIR}/docs/" CACHE PATH "Directory to install documentation")
endif (NOT DEFINED PCILIB_DOC_DIR)
if (NOT DEFINED PCILIB_DEBUG_DIR)
set(PCILIB_DEBUG_DIR "." CACHE PATH "Directory to write debug information")
endif (NOT DEFINED PCILIB_DEBUG_DIR)
+if (NOT DEFINED PCILIB_DYNAMIC_HEADERS_INC)
+ set(PCILIB_DYNAMIC_HEADERS_INC "-I${CMAKE_BINARY_DIR}")
+endif (NOT DEFINED PCILIB_DYNAMIC_HEADERS_INC)
+
SET(ENV{PKG_CONFIG_PATH} "${CMAKE_INSTALL_LIBDIR}/pkgconfig:$ENV{PKG_CONFIG_PATH}")
if (NOT DISABLE_PYTHON)