summaryrefslogtreecommitdiffstats
path: root/pcilib/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2016-02-26 02:14:55 +0100
committerSuren A. Chilingaryan <csa@suren.me>2016-02-26 02:14:55 +0100
commit30d740cc6accc3bd477e6bc924d5b74dad71ee6d (patch)
tree2e197791d23958258b34a3bc53cc5b0584ac7060 /pcilib/CMakeLists.txt
parent3ea1907f3169e0233d3a32a7d470af3c34b6f967 (diff)
parented7a7ff66c64cc2e164070865306e7d79652063a (diff)
downloadpcitool-30d740cc6accc3bd477e6bc924d5b74dad71ee6d.tar.gz
pcitool-30d740cc6accc3bd477e6bc924d5b74dad71ee6d.tar.bz2
pcitool-30d740cc6accc3bd477e6bc924d5b74dad71ee6d.tar.xz
pcitool-30d740cc6accc3bd477e6bc924d5b74dad71ee6d.zip
Merge of further work on Python scripting from Vasiliy Chernov
Diffstat (limited to 'pcilib/CMakeLists.txt')
-rw-r--r--pcilib/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/pcilib/CMakeLists.txt b/pcilib/CMakeLists.txt
index a7557b7..27543e4 100644
--- a/pcilib/CMakeLists.txt
+++ b/pcilib/CMakeLists.txt
@@ -8,7 +8,7 @@ include_directories(
${UTHASH_INCLUDE_DIRS}
)
-set(HEADERS pcilib.h pci.h datacpy.h memcpy.h pagecpy.h cpu.h timing.h export.h value.h bar.h fifo.h model.h bank.h register.h view.h property.h unit.h xml.h py.h kmem.h irq.h locking.h lock.h dma.h event.h plugin.h tools.h error.h debug.h env.h version.h config.h build.h)
+set(HEADERS pcilib.h pci.h datacpy.h memcpy.h pagecpy.h cpu.h timing.h export.h value.h bar.h fifo.h model.h bank.h register.h view.h property.h unit.h xml.h py.h kmem.h irq.h locking.h lock.h dma.h event.h plugin.h tools.h error.h debug.h env.h config.h version.h build.h)
add_library(pcilib SHARED pci.c datacpy.c memcpy.c pagecpy.c cpu.c timing.c export.c value.c bar.c fifo.c model.c bank.c register.c view.c unit.c property.c xml.c py.c kmem.c irq.c locking.c lock.c dma.c event.c plugin.c tools.c error.c debug.c env.c)
target_link_libraries(pcilib dma protocols views ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS} ${EXTRA_SYSTEM_LIBS} ${LIBXML2_LIBRARIES} ${PYTHON_LIBRARIES})
add_dependencies(pcilib build dma protocols views)
@@ -23,4 +23,4 @@ install(FILES pcilib.h
install(FILES bar.h kmem.h locking.h lock.h bank.h register.h xml.h dma.h event.h model.h error.h debug.h env.h tools.h timing.h cpu.h datacpy.h pagecpy.h memcpy.h export.h version.h view.h unit.h
DESTINATION include/pcilib
-) \ No newline at end of file
+)