summaryrefslogtreecommitdiffstats
path: root/pcitool/CMakeLists.txt
diff options
context:
space:
mode:
authorVasilii Chernov <vchernov@inr.ru>2016-02-24 18:24:22 +0100
committerVasilii Chernov <vchernov@inr.ru>2016-02-24 18:24:22 +0100
commitb0a034e6ef4a958235a56ebde0831c0f30a84d30 (patch)
treea1f46d2d536c692edd6b17efc61ac9fefef2796b /pcitool/CMakeLists.txt
parentda842568b94b0e00c1709ae01f441a7424c15b87 (diff)
parent3ea1907f3169e0233d3a32a7d470af3c34b6f967 (diff)
downloadpcitool-b0a034e6ef4a958235a56ebde0831c0f30a84d30.tar.gz
pcitool-b0a034e6ef4a958235a56ebde0831c0f30a84d30.tar.bz2
pcitool-b0a034e6ef4a958235a56ebde0831c0f30a84d30.tar.xz
pcitool-b0a034e6ef4a958235a56ebde0831c0f30a84d30.zip
Merge with Suren branch. Fix memory leaks.
Diffstat (limited to 'pcitool/CMakeLists.txt')
-rw-r--r--pcitool/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/pcitool/CMakeLists.txt b/pcitool/CMakeLists.txt
index 2f3639f..d8b5a6c 100644
--- a/pcitool/CMakeLists.txt
+++ b/pcitool/CMakeLists.txt
@@ -13,9 +13,9 @@ link_directories(
)
if (NOT DISABLE_PCITOOL)
- add_executable(pci cli.c sysinfo.c formaters.c)
- set(HEADERS ${HEADERS} sysinfo.h formaters.h)
- add_dependencies(pci pcilib)
+ set(HEADERS ${HEADERS} sysinfo.h formaters.h buildinfo.h)
+ add_executable(pci cli.c sysinfo.c formaters.c buildinfo.c)
+ add_dependencies(pci build pcilib)
target_link_libraries(pci pcilib ${FASTWRITER_LIBRARIES})
set_target_properties(pci PROPERTIES
LINK_FLAGS "${CMAKE_THREAD_LIBS_INIT} ${EXTRA_SYSTEM_LIBS}"