summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e62519..10742fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
project(pcitool)
-set(PCILIB_VERSION "0.2.1")
+set(PCILIB_VERSION "0.2.2")
set(PCILIB_ABI_VERSION "2")
cmake_minimum_required(VERSION 2.6)
@@ -36,13 +36,15 @@ find_package(Threads REQUIRED)
set(EXTRA_SYSTEM_LIBS -lrt)
+check_include_files(stdatomic.h HAVE_STDATOMIC_H)
+
+pkg_check_modules(LIBXML2 libxml-2.0 REQUIRED)
+
#Check in sibling directory
if (NOT DISABLE_PCITOOL)
pkg_check_modules(FASTWRITER fastwriter REQUIRED)
endif (NOT DISABLE_PCITOOL)
-check_include_files(stdatomic.h HAVE_STDATOMIC_H)
-
add_definitions("-fPIC --std=c99 -Wall -O2 -gdwarf-2 -g3 -fno-omit-frame-pointer")
#add_definitions("-fPIC --std=c99 -Wall -O2")
@@ -54,6 +56,7 @@ add_subdirectory(protocols)
add_subdirectory(pcilib)
add_subdirectory(pcitool)
add_subdirectory(apps)
+add_subdirectory(xml)
set_target_properties(pcilib PROPERTIES
VERSION ${PCILIB_VERSION}