summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2005-06-28 16:37:40 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2005-06-28 16:37:40 +0000
commite491cf8ad72d6752af8dac345d3bbc491e21a13a (patch)
treedb41b453a116c64cbac10f51aeec3c68d954cce6 /configure.in
parent70fbe7822024d0acc68df3607ff25bf8d7a71751 (diff)
downloadlibrcd-e491cf8ad72d6752af8dac345d3bbc491e21a13a.tar.gz
librcd-e491cf8ad72d6752af8dac345d3bbc491e21a13a.tar.bz2
librcd-e491cf8ad72d6752af8dac345d3bbc491e21a13a.tar.xz
librcd-e491cf8ad72d6752af8dac345d3bbc491e21a13a.zip
0.1.6
* Function name is changed to conform LibRCC naming conventions * AutoConf Improvements * Release Script * Other minor changes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 04ccc7c..1ad8cd6 100644
--- a/configure.in
+++ b/configure.in
@@ -2,9 +2,9 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(src/librcd.c)
PACKAGE=librcd
-LIBRCD_VERSION_MAJOR=0
-LIBRCD_VERSION_MINOR=1
-LIBRCD_VERSION_SUBMINOR=5
+LIBRCD_VERSION_MAJOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 1 | sed -e s/^$/0/`
+LIBRCD_VERSION_MINOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 2 | sed -e s/^$/0/`
+LIBRCD_VERSION_SUBMINOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 3 | sed -e s/^$/0/`
LIBRCD_VERSION=$LIBRCD_VERSION_MAJOR.$LIBRCD_VERSION_MINOR.$LIBRCD_VERSION_SUBMINOR
VERSION=$LIBRCD_VERSION
LIBRCD_VERSION_INFO=`echo $LIBRCD_VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
@@ -36,4 +36,4 @@ AC_C_CONST
dnl Checks for library functions.
-AC_OUTPUT(src/Makefile Makefile librcd.spec)
+AC_OUTPUT(src/Makefile examples/Makefile statgen/Makefile Makefile librcd.spec)