summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Frust <tobiasfrust@gmail.com>2016-06-30 10:13:01 +0200
committerTobias Frust <tobiasfrust@gmail.com>2016-06-30 10:13:01 +0200
commit5680aa99001cb50c707c4187cd8ada0c41a573dd (patch)
treefcbe575cd20e35dbe3d2b7def5e7c801d576aaf8 /src/CMakeLists.txt
parent1dc95b4eed7974549ef43a87e0777aa343b30fd4 (diff)
downloadods-5680aa99001cb50c707c4187cd8ada0c41a573dd.tar.gz
ods-5680aa99001cb50c707c4187cd8ada0c41a573dd.tar.bz2
ods-5680aa99001cb50c707c4187cd8ada0c41a573dd.tar.xz
ods-5680aa99001cb50c707c4187cd8ada0c41a573dd.zip
implemented virtual DetectorModule with simple send via udp
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 80196d9..8e2b5f4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -31,9 +31,16 @@ include_directories(
${BOOST_INCLUDE_DIRS}
)
+set(LINK_LIBRARIES ${LINK_LIBRARIES}
+ ${LIBCONFIGPP_LIBRARY}
+ ${Boost_LIBRARIES}
+)
+
set(SOURCES_CLIENT
+ "${CMAKE_SOURCE_DIR}/ConfigReader/ConfigReader.cpp"
"${CMAKE_SOURCE_DIR}/UDPClient/UDPClient.cpp"
- "${CMAKE_SOURCE_DIR}/main.cpp"
+ "${CMAKE_SOURCE_DIR}/DetectorModule/DetectorModule.cpp"
+ "${CMAKE_SOURCE_DIR}/main_client.cpp"
)
set(SOURCES_SERVER
@@ -43,5 +50,6 @@ set(SOURCES_SERVER
add_executable(onlineDetectorSimulatorServer ${SOURCES_SERVER})
add_executable(onlineDetectorSimulatorClient ${SOURCES_CLIENT})
+target_link_libraries(onlineDetectorSimulatorClient ${LINK_LIBRARIES})