summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-01 17:23:14 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-01 17:23:14 +0100
commite26a093b4036083f13265bcbde5eae442d502377 (patch)
tree1fd30bbeba4eb7c7ee6d1c6d4f5e9593f30882da /test/CMakeLists.txt
parentb29c78f818ac92f42621c69c29736fe5c8e32c6f (diff)
downloadlibuca-e26a093b4036083f13265bcbde5eae442d502377.tar.gz
libuca-e26a093b4036083f13265bcbde5eae442d502377.tar.bz2
libuca-e26a093b4036083f13265bcbde5eae442d502377.tar.xz
libuca-e26a093b4036083f13265bcbde5eae442d502377.zip
First draft at clean pco object construction
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt46
1 files changed, 24 insertions, 22 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7d829c3..63c46d7 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -14,26 +14,25 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/control.glade ${CMAKE_CURRENT_BINARY_
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/run.py ${CMAKE_CURRENT_BINARY_DIR})
# --- Build targets -----------------------------------------------------------
-add_executable(enum enum.c)
-add_executable(grab grab.c)
-add_executable(grab-async grab-async.c)
-add_executable(benchmark benchmark.c)
-
-target_link_libraries(enum uca)
-target_link_libraries(grab uca)
-target_link_libraries(grab-async uca)
-target_link_libraries(benchmark uca)
-
-if (GTK2_FOUND)
- include_directories(${GTK2_INCLUDE_DIRS})
- add_executable(control control.c)
- target_link_libraries(control
- uca
- ${GTK2_LIBRARIES}
- ${GTHREAD2_LIBRARIES}
- )
-endif()
-
+#add_executable(enum enum.c)
+#add_executable(grab-async grab-async.c)
+#add_executable(benchmark benchmark.c)
+
+#target_link_libraries(enum uca)
+#target_link_libraries(grab uca)
+#target_link_libraries(grab-async uca)
+#target_link_libraries(benchmark uca)
+
+#if (GTK2_FOUND)
+# include_directories(${GTK2_INCLUDE_DIRS})
+# add_executable(control control.c)
+# target_link_libraries(control
+# uca
+# ${GTK2_LIBRARIES}
+# ${GTHREAD2_LIBRARIES}
+# )
+#endif()
+#
# >>> TEMPORARY TEST EXECUTABLE <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
@@ -46,5 +45,8 @@ include_directories(
)
add_executable(test-gobject test-gobject.c)
-target_link_libraries(test-gobject uca-gobject ${GLIB2_LIBRARIES}
- ${GOBJECT2_LIBRARIES})
+target_link_libraries(test-gobject
+ uca-gobject
+ ${GLIB2_LIBRARIES}
+ ${GOBJECT2_LIBRARIES}
+ )