summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-07-04 16:46:30 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-07-04 16:46:30 +0200
commitb9ce6027dde8b3c6fd002d38e3cee07e7711d73c (patch)
tree3adf5e718ffc28f300f2449f115f628162fe96f2 /test/CMakeLists.txt
parent67d068f7c843e980141cbabad9560154024a1366 (diff)
downloadlibufodecode-b9ce6027dde8b3c6fd002d38e3cee07e7711d73c.tar.gz
libufodecode-b9ce6027dde8b3c6fd002d38e3cee07e7711d73c.tar.bz2
libufodecode-b9ce6027dde8b3c6fd002d38e3cee07e7711d73c.tar.xz
libufodecode-b9ce6027dde8b3c6fd002d38e3cee07e7711d73c.zip
Move timer functions into timer.{c,h}
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aea7b7d..7539c19 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,9 +1,20 @@
# --- Build test executable -------------------------------------------------
+include(CheckIncludeFile)
+
+check_include_file("sys/time.h" HAVE_SYS_TIME_H)
+
+if (NOT HAVE_SYS_TIME_H)
+ message(FATAL_ERROR "sys/time.h not found")
+endif()
+
include_directories(
${CMAKE_SOURCE_DIR}/src
)
-add_executable(ipedec ipedec.c)
+add_executable(ipedec
+ ipedec.c
+ timer.c)
+
target_link_libraries(ipedec ufodecode)
install(TARGETS ipedec DESTINATION ${BIN_INSTALL_DIR})