summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aea7b7d..7539c19 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,9 +1,20 @@
# --- Build test executable -------------------------------------------------
+include(CheckIncludeFile)
+
+check_include_file("sys/time.h" HAVE_SYS_TIME_H)
+
+if (NOT HAVE_SYS_TIME_H)
+ message(FATAL_ERROR "sys/time.h not found")
+endif()
+
include_directories(
${CMAKE_SOURCE_DIR}/src
)
-add_executable(ipedec ipedec.c)
+add_executable(ipedec
+ ipedec.c
+ timer.c)
+
target_link_libraries(ipedec ufodecode)
install(TARGETS ipedec DESTINATION ${BIN_INSTALL_DIR})