summaryrefslogtreecommitdiffstats
path: root/bin/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:53:29 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:54:12 +0200
commit06d5b3438f682307db06074ce9709b949a9aa846 (patch)
tree99dbeeab1eeab0d890ad1a32842ffb3540c782c5 /bin/gui/CMakeLists.txt
parent1cb1a541bedd4e17085ab8ce04d0f5b2fc4d8d1d (diff)
downloaduca-06d5b3438f682307db06074ce9709b949a9aa846.tar.gz
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.bz2
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.xz
uca-06d5b3438f682307db06074ce9709b949a9aa846.zip
Move binaries to bin and make ring buffer a lib
Diffstat (limited to 'bin/gui/CMakeLists.txt')
-rw-r--r--bin/gui/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/bin/gui/CMakeLists.txt b/bin/gui/CMakeLists.txt
new file mode 100644
index 0000000..f64bd02
--- /dev/null
+++ b/bin/gui/CMakeLists.txt
@@ -0,0 +1,41 @@
+cmake_minimum_required(VERSION 2.8)
+
+add_definitions("--std=c99 -Wall")
+
+# --- Find packages and libraries ---------------------------------------------
+find_package(PkgConfig)
+
+pkg_check_modules(GTK2 gtk+-2.0>=2.22)
+pkg_check_modules(GTHREAD2 gthread-2.0)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/control.glade
+ ${CMAKE_CURRENT_BINARY_DIR})
+
+# --- Build targets -----------------------------------------------------------
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+if (GTK2_FOUND)
+ include_directories(${GTK2_INCLUDE_DIRS})
+
+ add_executable(control
+ control.c
+ egg-property-cell-renderer.c
+ egg-property-tree-view.c
+ egg-histogram-view.c)
+
+ target_link_libraries(control
+ m
+ uca
+ ringbuffer
+ ${GTK2_LIBRARIES}
+ ${GTHREAD2_LIBRARIES})
+
+ install(TARGETS control
+ RUNTIME DESTINATION bin)
+
+ install(FILES control.glade
+ DESTINATION share/libuca)
+endif()