summaryrefslogtreecommitdiffstats
path: root/bin/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-16 13:45:38 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-16 13:45:38 +0200
commitd3c7ea71b67077921f023159f67b85a6794c681b (patch)
tree5bdd6d345146c41fe0942512ec5d7fa4da904ae6 /bin/gui/CMakeLists.txt
parent46837bbb16002174e67d42c0c0baf8a8e79a2337 (diff)
downloaduca-d3c7ea71b67077921f023159f67b85a6794c681b.tar.gz
uca-d3c7ea71b67077921f023159f67b85a6794c681b.tar.bz2
uca-d3c7ea71b67077921f023159f67b85a6794c681b.tar.xz
uca-d3c7ea71b67077921f023159f67b85a6794c681b.zip
Rename uca-control to uca-camera-control
Diffstat (limited to 'bin/gui/CMakeLists.txt')
-rw-r--r--bin/gui/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/bin/gui/CMakeLists.txt b/bin/gui/CMakeLists.txt
index b00054a..c42bf35 100644
--- a/bin/gui/CMakeLists.txt
+++ b/bin/gui/CMakeLists.txt
@@ -19,21 +19,22 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
if (GTK2_FOUND)
include_directories(${GTK2_INCLUDE_DIRS})
+ set(BINARY "uca-camera-control")
- add_executable(uca-control
+ add_executable(${BINARY}
control.c
egg-property-cell-renderer.c
egg-property-tree-view.c
egg-histogram-view.c)
- target_link_libraries(uca-control
+ target_link_libraries(${BINARY}
m
uca
ringbuffer
${GTK2_LIBRARIES}
${GTHREAD2_LIBRARIES})
- install(TARGETS uca-control
+ install(TARGETS ${BINARY}
RUNTIME DESTINATION bin)
install(FILES control.glade