summaryrefslogtreecommitdiffstats
path: root/plugins/pylon/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2014-04-09 12:09:54 +0200
committerMihael Koep <koep@schneide.com>2014-04-09 12:21:19 +0200
commit0e4338b82c6995f4b8647ec668a752b69085c052 (patch)
treed759a32cb099d286d0f6901d4a95387cc484622e /plugins/pylon/CMakeLists.txt
parent9136bc7ed3e057290bfd7d8a8beae424f1079182 (diff)
downloaduca-0e4338b82c6995f4b8647ec668a752b69085c052.tar.gz
uca-0e4338b82c6995f4b8647ec668a752b69085c052.tar.bz2
uca-0e4338b82c6995f4b8647ec668a752b69085c052.tar.xz
uca-0e4338b82c6995f4b8647ec668a752b69085c052.zip
Make pylon plugin compatible with current libuca
Diffstat (limited to 'plugins/pylon/CMakeLists.txt')
-rw-r--r--plugins/pylon/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/plugins/pylon/CMakeLists.txt b/plugins/pylon/CMakeLists.txt
index 7e573f1..3f8569c 100644
--- a/plugins/pylon/CMakeLists.txt
+++ b/plugins/pylon/CMakeLists.txt
@@ -1,13 +1,13 @@
cmake_minimum_required(VERSION 2.6)
project(ucapylon C)
-set(VERSION "1.0.0")
+set(VERSION "1.1.0")
find_package(Pylon)
if (PYLON_FOUND)
set(UCA_CAMERA_NAME "pylon")
+ set(PLUGIN_REVISION "1")
set(PLUGIN_VERSION ${VERSION})
- set(PLUGIN_REVISION "2")
set(PLUGIN_SUMMARY "Pylon plugin for libuca")
set(PLUGIN_CHANGELOG "${CMAKE_CURRENT_SOURCE_DIR}/changelog.txt")
set(PLUGIN_DESCRIPTION "Plugin for the Basler GigE CCD Camera.")
@@ -25,10 +25,10 @@ if (PYLON_FOUND)
create_enums(uca-pylon-enums
${CMAKE_CURRENT_SOURCE_DIR}/../../src/uca-enums
uca-pylon-camera.h)
-
+
add_library(ucapylon SHARED
- uca-pylon-enums.c
- uca-pylon-camera.c)
+ uca-pylon-camera.c
+ uca-pylon-enums.c)
target_link_libraries(ucapylon
${UCA_DEPS}