summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-05 10:49:37 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-05 10:49:37 +0100
commit38a25bb40b18fc820157d9af832daf08bbc7cd9e (patch)
tree820fe465ef0be2fa0569e3eb5bca818d566a72d2 /test/CMakeLists.txt
parent06300e8df49b5767600bc65a8ad30a809004d6cf (diff)
downloaduca-38a25bb40b18fc820157d9af832daf08bbc7cd9e.tar.gz
uca-38a25bb40b18fc820157d9af832daf08bbc7cd9e.tar.bz2
uca-38a25bb40b18fc820157d9af832daf08bbc7cd9e.tar.xz
uca-38a25bb40b18fc820157d9af832daf08bbc7cd9e.zip
Use property notification instead of signal
Up to this point we used a custom signal to notify about starting and stopping recording of data. However, such signals come (almost) for free for each property. This way, you can query "is-recording" but also be notified when "is-recording" was changed by the camera itself.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index b853cb5..4ee097b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -51,9 +51,9 @@ target_link_libraries(test-gobject
${GOBJECT2_LIBRARIES}
)
-#add_executable(test-mock test-mock.c)
-#target_link_libraries(test-mock
-# uca-gobject
-# ${GLIB2_LIBRARIES}
-# ${GOBJECT2_LIBRARIES}
-# )
+add_executable(test-mock test-mock.c)
+target_link_libraries(test-mock
+ uca-gobject
+ ${GLIB2_LIBRARIES}
+ ${GOBJECT2_LIBRARIES}
+ )