summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-21 12:11:55 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-21 12:11:55 +0200
commit9f262857d13a3e0d7ee214b33b90359c51227718 (patch)
treeb0c2bad6ba10037703785e2c695a65af621c5a32 /test/CMakeLists.txt
parent7132f5b74e74597fea4e358381e9e102bba7c8ed (diff)
downloaduca-9f262857d13a3e0d7ee214b33b90359c51227718.tar.gz
uca-9f262857d13a3e0d7ee214b33b90359c51227718.tar.bz2
uca-9f262857d13a3e0d7ee214b33b90359c51227718.tar.xz
uca-9f262857d13a3e0d7ee214b33b90359c51227718.zip
Port grab-async to new plugin manager
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ee5b407..e4e60dc 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -10,10 +10,7 @@ pkg_check_modules(GTHREAD2 gthread-2.0)
pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
-#include_directories(${CMAKE_SOURCE_DIR}/src)
-
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/control.glade ${CMAKE_CURRENT_BINARY_DIR})
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/run.py ${CMAKE_CURRENT_BINARY_DIR})
# --- Build targets -----------------------------------------------------------
include_directories(
@@ -37,16 +34,13 @@ if (HAVE_PYLON_CAMERA)
endif()
add_executable(grab grab.c)
-#add_executable(grab-async grab-async.c)
+add_executable(grab-async grab-async.c)
add_executable(benchmark benchmark.c)
target_link_libraries(benchmark uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
target_link_libraries(grab uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
-#target_link_libraries(grab-async uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
+target_link_libraries(grab-async uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
-#add_executable(grab_pylon grab_pylon.c)
-#target_link_libraries(grab_pylon uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
-#
if (GTK2_FOUND)
include_directories(${GTK2_INCLUDE_DIRS})