summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-21 16:57:55 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-21 16:57:55 +0100
commitb2470635500817bd045810bb387e69bd4588cee6 (patch)
tree76b448541d1f24d95b6ee27b68f68306c2e6f262 /test/CMakeLists.txt
parente56445a8a9dafabc81ca8715626f225b53262be5 (diff)
downloaduca-b2470635500817bd045810bb387e69bd4588cee6.tar.gz
uca-b2470635500817bd045810bb387e69bd4588cee6.tar.bz2
uca-b2470635500817bd045810bb387e69bd4588cee6.tar.xz
uca-b2470635500817bd045810bb387e69bd4588cee6.zip
Merge patch from Volker Kaiser
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c14e7ce..50aa2b8 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -7,6 +7,8 @@ find_package(PkgConfig)
pkg_check_modules(GTK2 gtk+-2.0)
pkg_check_modules(GTHREAD2 gthread-2.0)
+pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
+pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
include_directories(${CMAKE_SOURCE_DIR}/src)
@@ -20,7 +22,7 @@ add_executable(grab grab.c)
#add_executable(benchmark benchmark.c)
#target_link_libraries(enum uca)
-target_link_libraries(grab uca-gobject)
+target_link_libraries(grab uca-gobject ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
#target_link_libraries(grab-async uca)
#target_link_libraries(benchmark uca)
@@ -36,8 +38,6 @@ target_link_libraries(grab uca-gobject)
#
# >>> TEMPORARY TEST EXECUTABLE <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
-pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
-pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
include_directories(
${GLIB2_INCLUDE_DIRS}