summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-08-07 10:49:49 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-08-07 10:49:49 +0200
commitcf80a64090e1fe25593d8c5ee115db68898a70b2 (patch)
treeff2512b60015e753d5c822f01b45ce8d2fba36c0 /test/CMakeLists.txt
parentbbf38b88d0c9ce41d6c8a6f945b7154b75bd7c4d (diff)
downloaduca-cf80a64090e1fe25593d8c5ee115db68898a70b2.tar.gz
uca-cf80a64090e1fe25593d8c5ee115db68898a70b2.tar.bz2
uca-cf80a64090e1fe25593d8c5ee115db68898a70b2.tar.xz
uca-cf80a64090e1fe25593d8c5ee115db68898a70b2.zip
Update benchmark tool
The tool measures the bandwidth performance of a supplied camera. It outputs the results in standard space separated format that can be read with Numpy's loadtxt function.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 9050ce5..4f3bdc8 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -27,7 +27,9 @@ message("${CMAKE_CURRENT_SOURCE_DIR}")
add_executable(grab grab.c)
add_executable(grab-async grab-async.c)
+add_executable(benchmark benchmark.c)
+target_link_libraries(benchmark uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
target_link_libraries(grab uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
target_link_libraries(grab-async uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})