summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-21 11:59:06 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2012-09-21 11:59:06 +0200
commitec0e31d89baf7cb6c2fb30ead081655886478609 (patch)
tree804e349dae11b88c44b0caf77df6e5b8c1430c52 /test/CMakeLists.txt
parent10af0e5911e06d041874a3da7adafa3f21319def (diff)
downloaduca-ec0e31d89baf7cb6c2fb30ead081655886478609.tar.gz
uca-ec0e31d89baf7cb6c2fb30ead081655886478609.tar.bz2
uca-ec0e31d89baf7cb6c2fb30ead081655886478609.tar.xz
uca-ec0e31d89baf7cb6c2fb30ead081655886478609.zip
Port the unit tests to the plugin manager
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt26
1 files changed, 11 insertions, 15 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 651c805..ee5b407 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -47,10 +47,6 @@ target_link_libraries(grab uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
#add_executable(grab_pylon grab_pylon.c)
#target_link_libraries(grab_pylon uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
#
-#if (NOT DEFINED WITH_CONTROL_GUI)
-# set(WITH_CONTROL_GUI TRUE)
-#endif()
-#
if (GTK2_FOUND)
include_directories(${GTK2_INCLUDE_DIRS})
@@ -69,17 +65,17 @@ if (GTK2_FOUND)
DESTINATION share/libuca)
endif()
-#if (HAVE_MOCK_CAMERA)
-# add_executable(test-mock test-mock.c)
-#
-# target_link_libraries(test-mock
-# uca
-# ${GLIB2_LIBRARIES}
-# ${GOBJECT2_LIBRARIES})
-#
-# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/gtester.xsl
-# ${CMAKE_CURRENT_BINARY_DIR}/gtester.xsl)
-#endif()
+if (HAVE_MOCK_CAMERA)
+ add_executable(test-mock test-mock.c)
+
+ target_link_libraries(test-mock
+ uca
+ ${GLIB2_LIBRARIES}
+ ${GOBJECT2_LIBRARIES})
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/gtester.xsl
+ ${CMAKE_CURRENT_BINARY_DIR}/gtester.xsl)
+endif()
#add_executable(test-all test-all.c)
#target_link_libraries(test-all uca