summaryrefslogtreecommitdiffstats
path: root/plugins/dexela/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/dexela/CMakeLists.txt')
-rw-r--r--plugins/dexela/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugins/dexela/CMakeLists.txt b/plugins/dexela/CMakeLists.txt
index 8522192..03ff968 100644
--- a/plugins/dexela/CMakeLists.txt
+++ b/plugins/dexela/CMakeLists.txt
@@ -1,11 +1,23 @@
cmake_minimum_required(VERSION 2.8)
project(ucadexela C)
+set(VERSION "1.0.0")
find_package(DEXELA)
if (DEXELA_FOUND)
set(UCA_CAMERA_NAME "dexela")
+ set(PLUGIN_SPECIFIC_FLAGS "-D CMAKE_CURRENT_BINARY_DIR=`pwd` -D CPACK_RPM_USER_BINARY_SPECFILE=${CMAKE_CURRENT_BINARY_DIR}/ucadexela.spec")
+ set(CPACK_PACKAGE_VERSION ${VERSION})
+ set(CPACK_GENERATOR "RPM")
+ set(CPACK_PACKAGE_NAME "uca-plugin-dexela")
+ set(CPACK_PACKAGE_RELEASE 1)
+ set(CPACK_PACKAGE_CONTACT "Mihael Koep")
+ set(CPACK_PACKAGE_VENDOR "ANKA Computing Group")
+ set(CPACK_PACKAGING_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX})
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/ucadexela.spec.in
+ ${CMAKE_CURRENT_BINARY_DIR}/ucadexela.spec)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)